Moodle 3.5 wydane

Moodle 3.5 wydane

W dniu dzisiejszym (17.05.2018) opublikowane zostały nowe wersje systemu e-learningowego Moodle – 3.5, 3.4.3, 3.3.6, 3.2.9 oraz 3.1.12.

Nowością jest wydanie wersji 3.5, która wprowadza następujące nowości w systemie e-learningowym:

  • wsparcie dla RODO (GDPR) – dodane zostało narzędzie administracyjne pozwalające zarządzać dokumentami dotyczącymi polityki bezpieczeństwa systemu zdalnego nauczania wraz z przepływem informacji umożliwiającej użytkownikom wyrażenie zgody na zasady bezpieczeństwa, weryfikację wieku i lokalizacji celem identyfikacji nieletnich oraz zbiorczego akceptowania zasad w imieniu użytkownika. System pozwala na włączenie zasad, ich akceptację, pozwala na wyświetlenie zasad w stopce serwisu, a także tworzyć nowy podsystem prywatności przez administratora Moodle,
  • ulepszone tagowanie banku pytań w quizie – poprzez dodanie i edycję tagów, ich filtrowanie oraz możliwość importu/eksportu,
  • ulepszona funkcjonalność UX Bootstrap 4.0,
  • poprawiony edytor Atto,
  • wsparcie LTI Advantage 1.1,
  • poprawa systemu globalnego wyszukiwania w Moodle,
  • zmiany w funkcjonalności modułów SCORM, pracy kohort, odznak, informacji zwrotnej, poprawki w pytaniach typu esej, oceniania pytań, itp.,
  • a także liczne poprawki bezpieczeństwa.

Patrząc na powyższą listę, widać, że największą zmianą jest zgodność systemu Moodle 3.5 z nadchodzącym RODO, czyli ogólnym rozporządzeniem o ochronie i przetwarzaniem danych osób fizycznych.  Sama dyrektywa wchodzi w życie 25 maja 2018, tak więc niewiele dni zostało do aktualizacji systemu do najnowszej wersji wspierającej RODO (i oczywiście odpowiednie zaktualizowanie regulaminów i systemu pod ww. prawo).

Kolejna wersja systemu – to zaktualizowane drzewo 3.4 do wersji 3.4.3. Aktualizacja przynosi zmiany w SCORM, forum oraz warsztatach, a także poprawę działania kalendarza, lekcji czy naprawiono problem pobierania plików o długich nazwach. W systemie 3.4.x jest również zaimplementowany rdzeń pozwalający na zgodność z RODO (GPRD), leczy wymagane jest zainstalowanie zewnętrznych wtyczek, które nie będą znajdować się w standardowej dystrybucji systemu (to jest tylko w wersji 3.5 Moodle). W ciągu najbliższych dni mają się ukazać nowe wersje wtyczek wspierające prywatność danych/zasady do zainstalowania w systemie 3.4.3.

Podobne zmiany (jak w 3.4.3) są w systemie 3.3.6, który również będzie wspierał RODO (GPRD) za pomocą zewnętrznych wtyczek systemowych dostępnych z moodle.org.

Wersje 3.2.9 oraz 3.1.12 otrzymały jedynie poprawki bezpieczeństwa i nie wspierają dyrektywy RODO (GPRD).

Najnowsze wersje systemu Moodle można pobrać ze strony: https://download.moodle.org. Informacje o zmianach w poszczególnych wersjach systemu znajdują się tutaj:

Zachęcamy do aktualizacji systemu do najnowszej wersji – jest to gwarancja bezpieczeństwa oraz pewność zgodności systemu e-elearningowego z nadchodzącą dyrektywą dotyczącą polityki bezpieczeństwa i ochrony danych osobowych RODO (GPRD).

Dodaj komentarz